Ruby on Railsのバージョン違いで悩み続けているのは自分だけ?

すみません。最初に断っておきますが、Redmineを入れるためにRuby on Railsを入れようとしてまして、
それ自体は入ったのですが、
今度はGemだかRailsのバージョンだか何だかで、Redmineのインストールが出来ない。という状況に陥ってます。

これって、ふと思ったんですが、こんなことじゃ、クライアントに提供するアプリケーションなんて作れないんじゃないですかね?

ええっと、Railsはこのバージョンで、Gemはこのバージョンを入れてください。
ちょっとでも違うバージョンだと、もう動きませんので。

みたいな。なんじゃこりゃ。

ほとんど触った事ないで言ってますが、間違ってたら指摘してください。



コメントをどうぞ